Ticket #71 (closed: fixed)

Opened 17 years ago

Last modified 17 years ago

Loading Ecosim scenarios that are not already defined or trying to define them.....

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Database / Import Version:
Severity: minor Keywords:


Ok this is a lot of bug all in one......
but I think they are all related
Basically if I have a model and I try to create a scenario- it doesnt happen.

So I tried to create a scenario many times and I have some names saved in the senario menu- even though none of them work. SO I tried to delete them, and I get an error message Previously active Ecosim Scenario has been removed. GUI is in for a major shock, all ecosim data has been voided which is a really cute message and makes me laugh, but does this mean ALL my scenarios are now deleted?
I dont believe so because all of my other scenario names are there- even thought there is no information in the scenarios, but I wonder had there been something important in those files if they would have been altered.

Anyways I continued on deleting the rest of my files and it worked- I didnt get the doom GUI is in for a major shock message again, but rather are you sure you want to delete- fine.... until all are gone

Then I try to add a new one- doesnt happen. I am guessing you need one in there to start with in order to make it understand? So I have shot my self in the foot, and have to close the model.

When I open it again and go to input- run info- I now have 13 scenario 1's. Same model, not sure how they got there?, but none of them work for loading, even if I re-name them, even if i give them a wonderful description, nothing :-( They all fail to load database.

So basically if you import a model with a datebase for Ecosim attached it seems to work, but if you try to create your own scenario- not gonna happen

So I imported Lab1 (fish 501) and tried to see if the ecosim scenarios work, one of them does and the other doesn't load (go figure)- I had this problem before- and sent the database to Joren. Not sure what is happening, but Scenario test 1 works, but the manual fit scenario doesnt.

See bug 45- Or Joren, I think this is the same problem essentially with loading scenarios, or related to those ones.

Change History

comment:1 Changed 17 years ago by administrator

related to #43

comment:2 Changed 17 years ago by jeroens

A lot of changes have been made to prevent these errors.

  • Ecosim Create scenario works
  • Ecosim scenarios Save/Save? As works
  • Ecosim delete scenario debugged
  • Ecosim scenario definitions are kept up to date

The 'major shock' message has been removed now the GUI is able to survive when the active scenario is removed.

Note: See TracTickets for help on using tickets.