Ticket #486 (closed assessed: not an issue)

Opened 9 years ago

Last modified 8 years ago

Ecopath repeated prompts

Reported by: villyc Owned by: jeroens
Priority: low Milestone: Ecopath 6: release 6.0.8
Component: Ecopath Version:
Severity: crash Keywords:
Cc:

Description

When all basic input parameters have been entered for a group, the basic parameterization comes and asks if I want to estimate BA etc. That's fine, but it continues to ask every time I move back to Ecosim even if I haven't changed any input parameters. That's annoying, so only ask again if input is dirty.

Change History

comment:1 Changed 9 years ago by jeroens

Joe, this should probably be handled in the core, where a tab would be kept on which messages have been sent. Such a tab should exist in Ecopath, Ecosim, etc. We could write a generic class to administrate this. The tab will be cleared whenever a relevant data change is made.

Ugh, more stuff!

comment:2 Changed 9 years ago by jeroens

Carie, this has been slightly changed although not yet as Villy intended. Users can decide to suppress specific messages until a model is reloaded. Messages will still be logged in the status panel.

comment:3 Changed 9 years ago by carieh

Hi Jeroen,
I just tried this with the georgia strait model. entering parameters to force a biomass accumulation, and I kept getting the error (as intended) So I clicked the box at the bottom of the pop-up message that says Use this answer automatically until the model has been reloaded which I think is how you are getting around it asking you every time...EXCEPT it causes the program to crash and close on me :-)

comment:4 Changed 9 years ago by jeroens

Build 6.0.4.5: tested but seems to work ok. Can you tell me what error you are trying to suppress, and what you did to make Georgia Strait throw the message?

comment:5 Changed 9 years ago by carieh

version 6.0.4.5
adding parameters to force BA does not cause any pop-ups or crashing anymore :-)

comment:6 Changed 9 years ago by carieh

However, if you click to parameterize the model ,and get the pop-up screen you can click ok to the Biomass accumulation. Now click anywhere in Ecosim tto load a scenario...you will get a crash. Id doesnt matter if you have a scenario open or not, just try to get into ecosim and it should crash on you.

comment:7 Changed 8 years ago by sunk

  • Type set to not assessed

comment:8 Changed 8 years ago by shermanl

  • Milestone changed from Ecopath 6: build 6.0.7 to Ecopath 6: build 6.0.8

comment:9 Changed 8 years ago by shermanl

  • Owner jeroens deleted

comment:10 Changed 8 years ago by jeroens

  • Owner set to jeroens
  • Severity changed from tweak to crash

Carie reported a crash, will have to assess.

comment:11 Changed 8 years ago by jeroens

  • Status changed from assigned to closed
  • Type changed from not assessed to assessed
  • Resolution changed from repoened to not an issue

Issue no longer seems to exist

Note: See TracTickets for help on using tickets.