Ticket #446 (closed: fixed)

Opened 9 years ago

Last modified 8 years ago

problem in showing the graph of mixed trophic impact.

Reported by: joeh Owned by: shermanl
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecopath Version:
Severity: minor Keywords:
Cc:

Description (last modified by jeroens) (diff)

erwin ardli <eriantoo@…> reported:
I would to inform that I have a problem during running the balanced model. It is a problem in showing a graph of mixed trophic impact. Please find in the attachment file the graph that I was mentioned.

Change History

comment:1 Changed 9 years ago by administrator

duplicate of #499

comment:2 Changed 9 years ago by joeh

Got the MTI.txt file from Erwin. In the file , instead of . is used as the decimal separator. Suggest Erwin to run EwE6 on an English OS or change the format of number via the Control Panel. Waiting for his reply.

comment:3 Changed 9 years ago by joeh

Erwin reported problem solved after changing the format of number in the Control Panel. Sherman please close this log if we don't have to support , as the decimal separator.

comment:4 Changed 9 years ago by joeh

I did some further investigation:
I coded the file writer which seems to be working fine both in English and French OS; . used as the decimal separator in the former and , in the latter. Who wrote the reader? I checked the code. The failure occurred inside the impacts.exe which read the file and then plot the data in a pyramid. This exe is from EwE5 and we use it because of the pyramid plotting. So looks like not much I can do in the code

comment:5 Changed 9 years ago by shermanl

JoeH,

Did you find out what type of failure was this in the exe? Was it still the ','/'.' problem. If this is the case, and we can't modify the exe, we'll want to make sure the output will always guarantee it's a ',' instead of a '.'. Is there a way we can do it? Or am I missing something?

comment:6 Changed 9 years ago by joeh

Hi Sherman

The failure in the pyramid.exe/mti.exe was caused by the decimal separator used in the text file that the exe read. The exe only recognizes '.' as the decimal separator even if the user is using, for example, a French OS. Since we can't modify the exe, I have make sure the text outputter will always guarantee the decimal separator is a '.'

comment:7 Changed 9 years ago by shermanl

The culture issues with commas has been fixed. in version 6.0.3.15. Please test this out. :)

comment:8 Changed 9 years ago by carieh

Sherman, can you please give me a step by step to retest, I am not understanding all the big words being used above. Thanks :-)

comment:9 Changed 9 years ago by shermanl

marta coll wrote:
Hello Ecopath-guys,
I found the problem with the MTI and the pyramids ... do you want to know? how much? ;-) ejejejeej....
No, seriourly, the problem seems to be that when the database is too far away for the core program then the program does not find the application of MTI or pyramids. So I just saved my model in the same folder than ecopath.exe and then it works. I tried with the different versions of 6 that I had installed and the latest from Sherman links all all work, so this is it.
Sherman, the last version you sent me though does not have the fixed bug regarding the flow diagram, I cant save it, but I suppose you know that.
Let me know if I can help more,
hugs
Marta

comment:10 Changed 9 years ago by shermanl

Jeroen wrote:

Wow!
So, the solution *could* be not to put the pyramid file in the Temp folder, but instead in the actual Pyramid.exe folder, and delete the file after it has been used.
Same treatment for Mixed Trophic Impact.exe.
Thanks for the help, Marta!

comment:11 Changed 8 years ago by jeroens

  • Status changed from assigned to closed
  • Resolution changed from repoened to fixed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.