Ticket #676 (closed assessed: fixed)

Opened 7 years ago

Last modified 2 years ago

Allow MPAs to overlap

Reported by: martac Owned by:
Priority: normal Milestone: Ecopath 6: Release 6.5
Component: Ecospace Version: 6.4.3
Severity: feature Keywords: MPAs, Ecospace
Cc:

Description

It looks like that MPAs are not able to coexist if they spatially overlap, even if they are apply to different fleets. So if I want to have more than one MPA, to apply them to different fleets, but that they overlap in space, they delete each other...which is not very handy, because then you have to redo them all the time...

This happened in 5 as far as I know and does in 6 as well

Change History

comment:1 Changed 7 years ago by jeroens

  • Status changed from new to closed
  • Severity changed from major to NOT SET
  • Resolution set to not an issue
  • Summary changed from MPAs areas in Ecospace disapear to MPAs areas in Ecospace disappear
  • Priority changed from high to normal
  • Type changed from NOT SET to assessed

Since MPAs cannot overlap, users will have to perform the same trick here as with habitats:

Say MPA 1 applies to fleet 1 only, and MPA 2 applies to fleet 2 only, but MPA 1 and MPA 2 overlap. To simulate this in Ecospace you will have to create a new MPA 3 for the overlap of 1 and 2, where MPA 3 applies to both fleet 1 and fleet 2.

This is a limitation by design to the way Ecospace stores MPA data and computes.

comment:2 Changed 7 years ago by jeroens

  • Status changed from closed to reopened
  • Resolution not an issue deleted
  • Severity changed from NOT SET to major
  • Milestone changed from NOT SET to Ecopath 6: build 6.1.0

This report now is an official change request. MPAs should be able to overlap in the Ecospace data structures

comment:3 Changed 7 years ago by jeroens

  • Severity changed from major to feature

comment:4 Changed 7 years ago by jeroens

  • Milestone changed from Ecopath 6: build 6.1.0 to Ecopath 6: build 6.1.1

comment:5 Changed 7 years ago by jeroens

  • Milestone changed from Ecopath 6: release 6.1.1 to Ecopath 6: release 6.2

comment:6 Changed 6 years ago by jeroens

  • Summary changed from MPAs areas in Ecospace disappear to Allow MPAs to overlap

comment:7 Changed 6 years ago by jeroens

  • Milestone changed from Ecopath 6: release 6.2 to NOT SET

comment:8 Changed 5 years ago by jeroens

We've got an idea. Considering planned dynamics, such as driving MPA maps with external data, allowing MPAs to open and close, etc, Ecospace needs a more nimble approach to evaluating fishing restrictions.

Internally, all MPA logic should be boiled down to a MPAFish(row, col, fleet) map that contains the amalgamation of all fishing prohibitions for every time step. This will simplify the Ecospace computations and will cater to future dynamics.

The database and map rendering logic are ready for this.

comment:9 Changed 2 years ago by jeroens

  • Status changed from reopened to closed
  • Version set to 6.4.3
  • Resolution set to fixed
  • Milestone changed from NOT SET to Ecopath 6: Release 6.5

We finally did it, thanks Gideon at al for the incentive!

Note: See TracTickets for help on using tickets.