Ticket #1600 (closed assessed: not an issue)

Opened 3 years ago

Last modified 3 years ago

MSY strange behaviour

Reported by: viliyc Owned by:
Priority: normal Milestone:
Component: MSY Version: 6.6 beta
Severity: minor Keywords:
Cc:

Description

I was checking the MSY calculations in Ecosim, and noticed some very strange behavior on the simple model I used for the purpose: Anchovy Bay (attached)

In the model Cod has an F of 0.15/year, but when running the MSY search the full compensation stops at 0.04 and crashes the cod. See screenshot. They then bounce briefly back at an F around 0.15 but crashes again. I’ve tried to make long-term (500 years) run in Ecosim where I gradually increase F from 0 to 0.15 and the model behaves absolutely reasonable in that case. The stationary fmsy is probably ok (around 0.09). I cannot figure out what is going on, but it is definitely not right. Worrisome as I have to run a bunch of models to get fmsy with short deadline.

Would you look into is, asap, please

Attachments

Anchovy Bay.EwEmdb.zip (170.8 KB) - added by jeroens 3 years ago.
Model to reproduce the error
Screenshot 2018-09-03 15.23.19.png (143.6 KB) - added by jeroens 3 years ago.
Example of the error

Change History

Changed 3 years ago by jeroens

Model to reproduce the error

Changed 3 years ago by jeroens

Example of the error

comment:1 Changed 3 years ago by jeroens

Chatted with Carl, he thought it was dynamic instability (which it indeed looked like) caused by foraging time adjustment. I couldn’t get it to show dynamic instability in Ecosim, but the problem disappeared when foraging time adjustment was set to 0 for all but marine mammals.

comment:2 Changed 3 years ago by jeroens

  • Status changed from new to closed
  • Resolution set to not an issue

comment:3 Changed 3 years ago by jeroens

  • Type changed from not assessed to assessed
Note: See TracTickets for help on using tickets.