Ticket #274 (closed: fixed)

Opened 17 years ago

Last modified 16 years ago

Ecosim scenarios WILL NOT RUN without a fleet

Reported by: carieh Owned by: administrator
Priority: normal Milestone: Ecopath 6: build 6.0.7
Component: Ecosim Version:
Severity: crash Keywords:


using the lab 4 seal cod model, I created a new Ecosim scenario (which had the default of 100 years) and tried to run the model. I ended up with the error index was outside the bounds of array and the model either doesnt run or runs for <5 years and crashes.

Sidenote: I did delete all of the fishing fleets in the model previously, but I cannot see why that should cause a crash in the output

I added a fleet- which DID NOT automatically update in the output screen, closed the output screen, re-ran the model, and now it works

If I delete the fleet and try to re-run, I get the same error message.

I am not sure of the necessity of this, but if you decide to leave as is, it needs to be made explicit in the manual that a dummy fleet is needed.

Change History

comment:1 Changed 17 years ago by joeb

This should be working now. At least from Ecosim's point of view. There could still be interfaces that don't like it.

comment:2 Changed 17 years ago by carieh

I can now delete all fleets and run in Ecosim. Also when I try to adjust the fishing mortality for individual groups/fleets in the biomass output screen, there are no options available for fleets (good to know that the model recognizes this)

comment:3 Changed 17 years ago by carieh

Check this in version having some issues in version3, but not sure what they are (index array out of bounds message when switching back to run ecosim)

comment:4 Changed 16 years ago by carieh

Will run without fleets

Note: See TracTickets for help on using tickets.